« June 2007 | Main | September 2007 »

July 13, 2007

More Network Trouble

So now that the dust has settled from the network crash, i noticed that one of my printers was not doing its job. It's on a Netgear print server that i must admit i bruised a bit over the past 6 months, but it had always been pretty strong. I bruised it by plugging the wrong power supply into the server without noticing for about 6 months. It turns out that a 12 volt supply will work with a 9 volt device, at least for a while.

What is odd is that I could talk to the device, but it has somehow had it's memory erased and I can't figure out how to get it to take new settings. I even tried upgrading the firmware, but the upgrade complained that i had the wrong hardware. I am at a bit of a loss since it seems the device 'could' work, but somehow, it's gotten amneisia.

If anyone has any idea how I can make this thing remember what it is, let me know. The print server is a Netgear PS121.

Posted by Hefe at 12:06 PM

July 12, 2007

Network Problems

I came home from having dinner last night with gmar and found that my internal network was having as very serious problem. I have and UPS that is connected directly to my linux servers and that is connected via a network connetion to a couple other boxes. The linux box has a little networked service that let's the boxes know if the power is gone. So anyway, my windows box had about 40 pop-up boxes showing lost connection / connected.

This of course was a little odd, and my son hefito told me he was have a lag problem playing xbox live. I poked around and found that if i disconnected one leg of my network that was connecting a part of the house via homeplug (a technique for sending data through elecltrical outlets) i could get the network back up and running.

I figured the problem was with the homeplug hardware, so i started swapping it out and testing different units to isolate the failure. I found that all of the units were bad so i decided that something had happened with my home power. I figured it had become a bit noisy or something.

I consolodated all the equipment into a single room and started connecting bits and pieces. I have 3 router/hubs (2 wireless) a set of 5 homeplugs (one wireless) and various computers, print servers, etc.

I started testing all these bits and pieces and after a bunch of configuring and swapping i found that the problem was a single port on my linksys router. The port that was connected to the homeplug port went bonkers whenever a cable was plugged into it. It started sending packets all over the network, flooding the network with useless traffic and making it unusable. Sort of a self initiated Denial of Service attack. I unplugged the the device from the bad port and gave the trusty linksys router a secondary role in the network infrastructure as it was once the main firewall protecting all my equipment from the evil outside world.

Now all is well at the manor house and i can still control the Internet to do my evil bidding.

What exactly did i learn from this? Well the most important lesson i learned is to not trust the stongest link in a system because sometimes even that breaks. The router that caused the whole problem had been a trusted part of my network for about 10 years and never caused any problem. The homepugs on the otherhand have been bothersome so it was easy to blame them. Also, look at the lites on the front of the router. They aren't just pretty, they can tell you something important, like you have a broadcast storm.

Posted by Hefe at 08:30 AM